[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4752: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4754: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4755: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
Red Eclipse • View topic - The HUD causes a FPS drop in 1.5.5

The HUD causes a FPS drop in 1.5.5

Get help for installation issues, playing problems, mapping troubles, etc
Forum rules
The forum is now in read only mode, please see: https://redeclipse.net/discuss

The HUD causes a FPS drop in 1.5.5

Postby Alxa » 30 Jun 2016 17:47

Hey, whats up?

Since the update, the HUD causes FPS drops on all maps (from 200 fps to 25 fps); i know this because when i'm in "spectator" or when i type "/showhud 0" everything comes back to normal.


This is my machine:

-Nvidia GTX 760 (currently using the 353.86 drivers from 1 year ago, the new ones are kinda buggy)
-Intel i5 2320
-Windows 7 home edition SP1 (i have updates deactivated)


This is the same problem Laggy reported some weeks ago (we both have Nvidia cards).

Do anyone have any idea why is this happening?

[EDIT]

Restcoser suggested using /hudminimal 1 in the meanwhile. And it works.

Also, i noticed that during the vote time the FPS drop stops even when you still can see the HUD.
Visit our clan webpage: >SOON<
Visit the Koos Youtube channel:
User avatar
Alxa
 
Posts: 168
Joined: 02 Oct 2014 01:37

Re: The HUD causes a FPS drop in 1.5.5

Postby qreeves » 01 Jul 2016 03:15

I don't know if it's the HUD per-se. The UI runs cubescript twice per frame to build the layout then render it, it is significantly slower when the UI becomes more complicated. The maps menu is a good example of this now. This will be solved in the future when we migrate to the new UI that Tesseract uses.
Quinton Reeves | Lead Developer, Red Eclipse
|
Contribute to Project Costs via or
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: The HUD causes a FPS drop in 1.5.5

Postby bonifarz » 01 Jul 2016 07:06

This sounds really weird. So, you say it's the in-game hud for the health bar, energy meter etc that causes a major drop in the frame rate?
The only new thing there is the flashing colour while health or impulse is regenerating, right? Or does the SDL2 stuff have any effect on 2d stuff?
Alxa, do you get any error messages in the game console, such as textures or variables that cannot be found? Last time i had a big drop in fps it was due to a missing submodule update.
| | | |
User avatar
bonifarz
 
Posts: 1063
Joined: 03 Feb 2014 10:15

Re: The HUD causes a FPS drop in 1.5.5

Postby shacknetisp » 01 Jul 2016 16:58

Laggy reports that inventoryinput is the problem. If the inventoryinput is invisible, the lag goes away. So the temporary solution is to set: /inventoryinput 0
Beha | Leader of the | |
User avatar
shacknetisp
 
Posts: 177
Joined: 21 Sep 2014 01:48

Re: The HUD causes a FPS drop in 1.5.5

Postby bonifarz » 01 Jul 2016 18:21

Aha, interesting. Right, I can also see a drop in fps. Now, I wonder, why should anybody want to use inventoryinput 1 or 3, i.e. indicate which keys you press :)
| | | |
User avatar
bonifarz
 
Posts: 1063
Joined: 03 Feb 2014 10:15

Re: The HUD causes a FPS drop in 1.5.5

Postby shacknetisp » 01 Jul 2016 18:23

I guess 1 and 3 are there for the sake of completeness, but even inventoryinput 2 has the lag in spec mode.
Beha | Leader of the | |
User avatar
shacknetisp
 
Posts: 177
Joined: 21 Sep 2014 01:48

Re: The HUD causes a FPS drop in 1.5.5

Postby Alxa » 02 Jul 2016 21:52

Visit our clan webpage: >SOON<
Visit the Koos Youtube channel:
User avatar
Alxa
 
Posts: 168
Joined: 02 Oct 2014 01:37

Re: The HUD causes a FPS drop in 1.5.5

Postby qreeves » 03 Jul 2016 03:02

You can see all messages in the console by pressing (`~ or /).
Quinton Reeves | Lead Developer, Red Eclipse
|
Contribute to Project Costs via or
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: The HUD causes a FPS drop in 1.5.5

Postby Alxa » 04 Jul 2016 21:14

Oh yeah, i just thought you needed to activate some kind of debugger or something. But anyway, the game runs fine now. Thanks guys.
Visit our clan webpage: >SOON<
Visit the Koos Youtube channel:
User avatar
Alxa
 
Posts: 168
Joined: 02 Oct 2014 01:37


Return to Help and Support

cron