[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 483: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 379: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/bbcode.php on line 112: preg_replace(): The /e modifier is no longer supported, use preg_replace_callback instead
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4752: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4754: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4755: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
[phpBB Debug] PHP Warning: in file [ROOT]/includes/functions.php on line 4756: Cannot modify header information - headers already sent by (output started at [ROOT]/includes/functions.php:3887)
Red Eclipse • View topic - Segmentation Fault 11 during startup

Segmentation Fault 11 during startup

Get help for installation issues, playing problems, mapping troubles, etc
Forum rules
The forum is now in read only mode, please see: https://redeclipse.net/discuss

Segmentation Fault 11 during startup

Postby wilkgr » 29 Aug 2016 10:19

Last edited by wilkgr on 30 Aug 2016 22:30, edited 2 times in total.
wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State

Re: Segmentation Fault 11 during startup (no log files made

Postby qreeves » 29 Aug 2016 13:12

Intel cards are really hit or miss. There's some basic information for setting up a debug build and getting a backtrace from the crash here: .
Quinton Reeves | Lead Developer, Red Eclipse
|
Contribute to Project Costs via or
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: Segmentation Fault 11 during startup (no log files made

Postby bonifarz » 29 Aug 2016 14:16

Mhm, I think there's serveral players with integrated chips on older intel CPUs that can run the game fine on win10-64.

Before you dig into the details of debug builds, maybe it helps to run the launcher (redeclipse.bat) once as admin? I don't know, maybe something went wrong with fetching some updates.
| | | |
User avatar
bonifarz
 
Posts: 1063
Joined: 03 Feb 2014 10:15

Re: Segmentation Fault 11 during startup (no log files made

Postby wilkgr » 30 Aug 2016 00:54

wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State

Re: Segmentation Fault 11 during startup

Postby bonifarz » 30 Aug 2016 09:14

| | | |
User avatar
bonifarz
 
Posts: 1063
Joined: 03 Feb 2014 10:15

Re: Segmentation Fault 11 during startup

Postby wilkgr » 30 Aug 2016 22:35

wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State

Re: Segmentation Fault 11 during startup

Postby qreeves » 31 Aug 2016 09:38

If you've installed Code::Blocks, you press the "Debug & Run" button on the toolbar or use "Debugging -> Run". This will compile it and run it inside the debugger. You don't use the shortcut or batch files for this. I'm sorry, but this is a little difficult, unfortunately it is the only real way we have of knowing the real problem.
Quinton Reeves | Lead Developer, Red Eclipse
|
Contribute to Project Costs via or
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: Segmentation Fault 11 during startup

Postby wilkgr » 31 Aug 2016 10:22

wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State

Re: Segmentation Fault 11 during startup

Postby qreeves » 31 Aug 2016 11:35

Argh, I forgot Code::Blocks doesn't come with mingw64. It might work if you select "redeclipse-x86-dbg" before pressing debug, like so:
Clipboard01.jpg
Quinton Reeves | Lead Developer, Red Eclipse
|
Contribute to Project Costs via or
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: Segmentation Fault 11 during startup

Postby wilkgr » 31 Aug 2016 23:01

Last edited by wilkgr on 01 Sep 2016 00:36, edited 1 time in total.
wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State

Re: Segmentation Fault 11 during startup

Postby wilkgr » 01 Sep 2016 00:35

wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State

Re: Segmentation Fault 11 during startup

Postby qreeves » 01 Sep 2016 01:44

Yeah, that's a crash inside your driver DLL, not inside Red Eclipse. There isn't much we can do about these because the libraries don't provide valid backtraces (as you can see, it isn't very descriptive). Some people have experienced success trying different driver versions (not always being the latest one that works either), but unfortunately trying this isn't guaranteed to work, nor is there any hard evidence to follow to put you on the right track either. This is why you don't get too many games claiming to support Intel graphics cards, they suck :P
Quinton Reeves | Lead Developer, Red Eclipse
|
Contribute to Project Costs via or
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: Segmentation Fault 11 during startup

Postby wilkgr » 01 Sep 2016 01:48

wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State

Re: Segmentation Fault 11 during startup

Postby qreeves » 01 Sep 2016 06:30

Quinton Reeves | Lead Developer, Red Eclipse
|
Contribute to Project Costs via or
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: Segmentation Fault 11 during startup

Postby wilkgr » 01 Sep 2016 07:20

wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State

Re: Segmentation Fault 11 during startup

Postby wilkgr » 21 Sep 2016 01:58

So, it didn't work out :/

But thanks for taking the time to work through it with me :D
wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State

Re: Segmentation Fault 11 during startup

Postby qreeves » 21 Sep 2016 02:43

No problem, sorry you weren't able to play :(
Quinton Reeves | Lead Developer, Red Eclipse
|
Contribute to Project Costs via or
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: Segmentation Fault 11 during startup

Postby Iceflower » 23 Sep 2016 18:10

I know my English is cruel. :$
When I talk rubbish correct me.
User avatar
Iceflower
 
Posts: 208
Joined: 16 May 2014 21:44
Location: Germany

Re: Segmentation Fault 11 during startup

Postby qreeves » 24 Sep 2016 05:09

Yeah, that one looks like a crash in the shaders. Intel drivers have never been very compliant in that area. The reason we're seeing this more now is that the old software rendering pipeline was removed along with the upgrade to SDL2 and newer OpenGL versions. The last version that supports software rendering which might work with these GPUs is v1.5.3 (Aurora Edition), but realise that older versions aren't supported by the project.




Quinton Reeves | Lead Developer, Red Eclipse
|
Contribute to Project Costs via or
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: Segmentation Fault 11 during startup

Postby Iceflower » 24 Sep 2016 09:17

Thanks. 1.5.3 is working. Thats enough for my purposes. (ATM)
I know my English is cruel. :$
When I talk rubbish correct me.
User avatar
Iceflower
 
Posts: 208
Joined: 16 May 2014 21:44
Location: Germany

Re: Segmentation Fault 11 during startup

Postby wilkgr » 13 Jun 2017 05:15

1.5.8 works with -du0

On a different note, it used to be possible to spawn bots that would fight each other but not kill the player. Pressing [INSERT] now spawns bots that do kill the player, also when using edit mode. Is this possible somehow?
wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State

Re: Segmentation Fault 11 during startup

Postby qreeves » 13 Jun 2017 08:36

Quinton Reeves | Lead Developer, Red Eclipse
|
Contribute to Project Costs via or
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: Segmentation Fault 11 during startup

Postby wilkgr » 13 Jun 2017 09:59

Thank you!! :)
wilkgr
 
Posts: 11
Joined: 29 Aug 2016 10:07
Location: The Sunshine State a.k.a. The Smart State


Return to Help and Support

cron