[Bug] SVN - Residuals sound choppy

Issues that were previously reported and since dealt with.
Forum rules
This issue tracker is now in read-only mode. Please see this topic for more information on how to contribute to Red Eclipse.

[Bug] SVN - Residuals sound choppy

Postby insanity » 21 Sep 2014 01:53

In SVN RE, when the sound effects for residuals (bleed, burn, electricity) are playing all sound effects become very choppy and distorted. It sounds as if the underwater sound effect is playing as well, maybe that's related? Example videohttps://owncloud.isrv.pw/public.php?service=files&t=69d78c97400f72f19c1acc8849a4ff01
User avatar
insanity
 
Posts: 43
Joined: 29 Jul 2014 16:04
Location: The Asylum

Re: [Bug] SVN - Residuals sound choppy

Postby qreeves » 29 Sep 2014 05:50

I can't reproduce this issue, but I am aware of intermittent reports with similar complaints. We're basically at the mercy of SDL mixer, you might want to play with your sound* setttings.
Quinton Reeves | Lead Developer, Red Eclipse
Check Out My YouTube Channel | Leave Me a Tip on PayPal
Contribute to Project Costs via PayPal or Patreon
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: [Bug] SVN - Residuals sound choppy

Postby insanity » 01 Oct 2014 01:52

After more tinkering, it sounds like playing lots of SFX at once causes the issue for me. Spamming the flamer and jumping is often enough to start choppiness. I've played with sound vars, but no luck yet. I don't have this issue in r6550, did sounds change much between then? Maybe more SFX play at once in recent revisions?
User avatar
insanity
 
Posts: 43
Joined: 29 Jul 2014 16:04
Location: The Asylum

Re: [Bug] SVN - Residuals sound choppy

Postby qreeves » 01 Oct 2014 02:02

Yes, in order to resolve repeated on/off events all sounds play regardless of if they can be heard so they don't stop and restart on turbofire. Use "soundcull 1" to restore the old behaviour.
Quinton Reeves | Lead Developer, Red Eclipse
Check Out My YouTube Channel | Leave Me a Tip on PayPal
Contribute to Project Costs via PayPal or Patreon
User avatar
qreeves
Site Admin
 
Posts: 1619
Joined: 02 Feb 2014 05:04
Location: Australia

Re: [Bug] SVN - Residuals sound choppy

Postby Elwe » 01 Oct 2014 14:17

have you tried "make clean" before compiling?
Elwe
 
Posts: 13
Joined: 23 Apr 2014 08:58

Re: [Bug] SVN - Residuals sound choppy

Postby shirepirate » 12 Oct 2014 22:52

it's worth noting with the new sound behavior if there are too many sound entities (it takes a ridiculous amount though) the sfx of the player and parkour will not play
For every action, there is an equal and opposite reaction. For every freedom, there is a new limit. For every joy, a new sorrow. For every act of kindness, an unspeakable cruelty. Where someone succeeds, someone else fails. A new association means a new separation. Loyalty meets treachery, honor breeds disgrace, free expression yields censorship. Each piece of knowledge forms new ignorance. Even death gives rise to new life. But the balance of existence is the beginning of wisdom and discernment.
User avatar
shirepirate
 
Posts: 704
Joined: 27 Mar 2014 07:20


Return to Closed Issues

cron